معرفی EVN (مجازی سازی شبکه)

Network Virtualization

EVN تکنیک مجازی سازی منحصر به Cisco برای ایجاد شبکه مجازی جداگانه تحت یک زیرساخت مشترک است، که به هریک از این شبکه های مجازی این امکان را می دهد که مانند یک شبکه فیزیکی مجزا رفتار کنند و سرویس ها و منابع خود را در اختیار کاربران قرار دهند.

EVN یک مفهوم کاملاً جدید نیست بلکه آن در قبلا در تکنولوژی های مثل VRF-lite و MPLS VPN مورد استفاده قرار گرفته است.

در واقع EVN شباهت بسیار زیادی به VLAN بندی شبکه دارد البته با این تفاوت اساسی که در EVN مجازی سازی در لایه ۳ انجام میگردد و نسبت به تکنیک های قبلی ساده تر و به دلیل مصرف کمتر منابع (CPU, Memory) از Scalability بیشتری برخوردار است.

env
Virtualized Networks

چه مشکلاتی با EVN قابل حل است

مهم ترین مزیت EVN امکان استفاده از منابع شبکه (Router، Switch، پهنای باند و …) به صورت مشترک بدون نیاز به استفاده ایجاد یک شبکه فیزیکی مجزاست.

علاوه به مزیت های ذکر شده به دلیل سادگی در پیاده سازی، EVN منجر به کاهش هزینه deploy و نگهداری شبکه نیز می گردد.

مزیت EVN نسبت به VRF-lite و MPLS VPN

  • EVN علاوه بر دارا بودن تمامی مزیت های VRF-lite مانند path isolation و route replication به دلیل استفاده از اجزایی مانند  VNET trunk, VNET tag و سایر ابزارهای مدیریتی پیاده سازی Virtualization در شبکه تا حد زیادی ساده کرده است.
  • در مقایسه با MPLS VPN، سادگی در پیکر­بندی و عدم نیاز به MPBGP برای route replicate  مابین VRF ها مهم ترین مزیت EVN بشمار می رود.

Multi-VRF Core Interface Configuration

EVN Core Interface Configuration

!

interface TenGigabitEthernet1/1

ip address 10.122.5.31 255.255.255.254

ip pim query-interval 333 msec

ip pim sparse-mode

logging event link-status

interface TenGigabitEthernet1/1.101

description Subinterface for Red VRF

encapsulation dot1Q 101

ip vrf forwarding Red

ip address 10.122.5.31 255.255.255.254

ip pim query-interval 333 msec

ip pim sparse-mode

logging event subif-link-status

interface TenGigabitEthernet1/1.102

description Subinterface for Green VRF

encapsulation dot1Q 102

ip vrf forwarding Green

ip address 10.122.5.31 255.255.255.254

ip pim query-interval 333 msec

ip pim sparse-mode

logging event subif-link-status

!

!

vrf definition Red

vnet tag 101

vrf definition Green

vnet tag 102

!

interface TenGigabitEthernet1/1

vnet trunk

ip address 10.122.5.32 255.255.255.254

ip pim query-interval 333 msec

ip pim sparse-mode

logging event link-status

!

جدول ۱:مقایسه پیکربندی مجازی سازی شبکه در EVN و Multi-VRF

پاسخ دهید

نشانی ایمیل شما منتشر نخواهد شد. بخش‌های موردنیاز علامت‌گذاری شده‌اند *